can not see my units

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

can not see my units

Heinz Guderian
Just trying to make a game.  Everything works but I can not see the units on the map.  When I move the cursor over a territory I can see the units on the tab territory.  I can select everything and do everything but no units on the map.  Does somebody knows the solution for it?
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Pulicat
Do you have show units turned off?
how now brown cow?
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Prussia
In reply to this post by Heinz Guderian
Simply do:

View => check "Show units"
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Heinz Guderian
I've already checked that, show units is on, turned especially off and back on, no result.
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Pulicat
Check the unit art. Are they there? Are they in the right formant? (png transparency -- on photoshop its called png-24 i believe).

Check the place.txt
Are the placement locations all wack?
how now brown cow?
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Heinz Guderian
I've copied the units from another game.  When I'm looking in the place.txt I see that the coordinates all have a minus, for example (-2512,-142).  I've changed one coordinate to positive but no result.

What do you mean with 'wack'?
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Veqryn
Administrator
obviously negative numbers will not do...

i am not sure if you know this but (0,0) is the top left corner of the map, and (10,5) would be 10 pixels to the right, and 5 pixels down (from the top left).

view other map's files to understand why yours does not work

also, the placement needs to be WITHIN the polygons to show up, otherwise i think they disappear
Please contribute to the TripleA 2013 donation drive:
http://tripleadev.1671093.n2.nabble.com/2013-TripleA-Donation-Drive-tp7583455.html
Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Bas71
I've had the same issue, has something to do with a bug in the tool that creates place.txt. Issue is solved by Wisconsin. You need to temporary remove map.properties and insert the unit-scale manually. Check here:

http://triplea.sourceforge.net/mywiki/Forum#nabble-td4732519|a4732826

And especially here:
http://triplea.sourceforge.net/mywiki/Forum#nabble-td4616118i20|a4780275


Reply | Threaded
Open this post in threaded view
|

Re: can not see my units

Heinz Guderian
Bedankt maatje,

Negative numbers and coordinates were out of the map.  Just removing the map-properties file temporarily is the solution.  Just one thing, I've entered both times 0.5625 for imigescale but when starting the game the unitsize was at 100%